Jump to content

Recommended Posts

Всем привет.

Имеется такая схема:  кластер на 2-х HW1000, 2 коммутатора HP Procurve 8212. Каждая нода поключена к своему коммутатору, коммутаторы настроены одинаково.

Так вот ситуация такая: если активна нода1 через коммутатор1, всё работает нормально. Если делаем активной ноду2 через коммутатор2, (то все работает до тех пор, такое ощущение что пока не пропадет сетевая активность, как правило это случается ночью),  кластер переключается назад на ноду1. 

В это время на коммутаторе2 видим кратковременную блокировку портов к которым подключен випнет,  сейчас сетевик сделал чтобы порты сразу же разблокировались, однако ничего не изменилось. С нодой1 и коммутатором1 такого не наблюдается.

Так же есть ещё одна сеть випнет, которая подключена аналогично и наблюдается та же самая ситуация.

Уже не знаю в какую сторону копать, может попробовать поиграться с параметрами секции network в конфиге кластера, хотя и так уже увеличил timeout до 5 секунд.

Может была у кого похожая ситуация? Куда копнуть?

 

Share this post


Link to post
Share on other sites
18 час назад, KIV сказал:

Причина блокировки какая? STP?

Да, STP.

Share this post


Link to post
Share on other sites

Так а пробовали STP на этом VLAN отключать к которому hw1000 подключен? В VLAN кроме КШ никого нет ктобы адреса кластера занимал? Никаких плюшек не включено на предмет контроля мак адреса файловера?

Share this post


Link to post
Share on other sites
14 часов назад, KIV сказал:

Так а пробовали STP на этом VLAN отключать к которому hw1000 подключен? В VLAN кроме КШ никого нет ктобы адреса кластера занимал? Никаких плюшек не включено на предмет контроля мак адреса файловера?

Не в VLAN-е больше никого, контроля тоже нет. А STP как то боязно отключать, на коммутаторе в других VLAN-х ещё много чего подключено, и если коммутатор ляжет ... то будет плохо.

Share this post


Link to post
Share on other sites

Ни у кого нет больше ни каких предположений? Кто виновник данной ситуации? Vipnet  или коммутатор?  На випнете увеличил параметры:

chektime =15

timeout=7

channelretries=5

activeretries=5

synctime=5

После этого одну ночь поработало, а на следующую переключилось, вобщем не помогло.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.