Jump to content
Sign in to follow this  
ettavolt

CSP lib failure: PRG_CHECK_FAILURE при установке TLS GOST соединения

Recommended Posts

КриптоПро CSP был удалён,  ViPNet CSP 4.2.5.35526 свежепереустановленный, сертификатов нет, ключевых контейнеров нет (не подключен токен), шифры 2012 года включены/отключены, поддержка TLS 1.2 включена/отключена. Подключаемые устройства - Rutoken ECP  и/и не Infotecs Software Token. Проверка целостности - нет проблем. https://www.ssllabs.com/ssltest/viewMyClient.html - доступен TLS_GOSTR341001_WITH_28147_CNT_IMIT (0x81).

После информационного сообщения "ERROR! - CSP lib failure: PRG_CHECK_FAILURE." в журнале есть запись "Ошибка открытия ключевого контейнера:  Имя контейнера: (null).  Флаги: 0xF0000000.  Код ошибки: 0x30000000."
 

tls_fail.evtx

Share this post


Link to post
Share on other sites

Аналогичная ситуация. Пытаюсь установить соединение TLS 1.0 c  TLS_GOSTR341112_256_WITH_28147_CNT_IMIT - происходит тоже самое что и у топикстартера.

Share this post


Link to post
Share on other sites

Добрый день!

Можете уточнить свои ОС?

Share this post


Link to post
Share on other sites

В ходе дальнейших испытаний удалось установить, что даже CSP версии 4.2.2 не совместим с "расширенным безопасным режимом". Использование/не использование "64-разрядных процессов в расширенном защищённом режиме" не влияет на результат.

Помниться где-то я встречал утверждения, что этот "расширенный защищённый режим" изменяет адреса используемой памяти.

 

Share this post


Link to post
Share on other sites

Добрый день!

Можете проверить на новой бета-версии CSP 4.2.5.40127?

Share this post


Link to post
Share on other sites

 

Попробовал ViPNet_CSP_RUS_4.2.8.47279_BETTA. Windows 8.1 amd64 с час назад установленными обновлениями.

Первая пачка событий в журнале (с 46-й минуты): запуск IE без "расширеного защищённого режима" (TLS-соединение устанавливается). Вторая (с 47-й) - со включённым "расширенным защищённым режимом" (TLS-соединение не устанавливается).

Сейчас ошибка выглядит как информационное сообщение со строкой "E:0x30000000(805306368)".

 

Прошу прощения за долгое отсутствие. ☺ 
 

tls_fail.4.2.8.b.evtx

Share this post


Link to post
Share on other sites
В 22.08.2017в20:59, ettavolt сказал:

запуск IE без "расширеного защищённого режима"

Где находится эта настройка?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.