Jump to content
Sign in to follow this  
Wad3r

VipNet CSP и .NET

Recommended Posts

Здравствуйте. При использовании VipNet CSP + InternetExplorer удается подключиться к интернет ресурсу через защищенное соединение. Однако, через собственную .net программу подключиться к ресурсу не получается: Ошибка установления SSL/TLS соединения. Поддерживает ли VipNet CSP работу с .net приложениями и если да, то как можно исправить такую ошибку?

Спасибо.

Share this post


Link to post
Share on other sites

Приветствую!

Если .NET программа использует системный TLS (а обычно так и есть), то проблем с соединением не возникает.

Из популярных ошибок.

1) IE обычно не проверяет сертификат сервера на отзыв. API, наоборот, обычно делает такую проверку. Часто проблема в недоступности или недействительности CRL.

2) Также при использовании двустороннего TLS нужно обратить внимание на правильное предоставление в API клиентского сертификата.

 

Больше без описания подробностей (к какому интернет ресурсу, при помощи какого API .NET и т.п.) ничего сказать нельзя.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.