Jump to content

Recommended Posts

Добрый день. Помогите пожалуйста разобраться в проблеме такого рода. Есть не большая сеть (25 машин), установлен VipNet coordinator HW/KB 1000, на клиентах стоит ViPNet Client 4.3.2, Kaspersky net agent + KES 10, парк ОС Windos 7 x86 + Windows 8.1 x64. Суть вопроса в том что на некоторых машинах постоянно крашиться VipNet Client, выдает ошибку: Программа Monitor.exe перезапущена из-за ошибки. Переустановка программы не помогает, ошибка остается. Ставил ViPNet Client на чистую систему только что установленную, потом только KES, ошибка все равно присутствует. Причем ошибку выдает на разных ОС, как на Win 7 так и на Win 8.1, хотя на многих работает нормально. Подскажите пожалуйста куда копать и в чем может быть проблема. 

Share this post


Link to post
Share on other sites

Попробуйте на KES отключить МЭ. В целом они нормально дружат, но всё же.

Посмотрите в журналах, может там подсказка с чем они в драку вступают.

Попробуйте другую сборку клиента (на сайте есть) если вам можно, ОЧЕНЬ часто то, что сертификаты ФСБ и ФСТЭК имеет очень много косяков имеет,

которые оперативно не могут исправить.

Ну и не исключении CSP которое так же имеет кучу проблем.

И рекомендую ОБЯЗАТЕЛЬНО отключить ддурное обновление ОС!!! Там столько "Г" лезит без контрольно, что ужас. Потому если что то надо то обновили в ручную, проверили что всё номрально и оставили. Если что то начинает сбоить то ищите подставные KB-шки.

Share this post


Link to post
Share on other sites

4.3.2 не очень, 4.3.1 пользуетесь. Основное в 4.3.2 это поддержка Win 10, у вас как я понял их нет.

Share this post


Link to post
Share on other sites
13 часов назад, Vintik сказал:

Попробуйте на KES отключить МЭ. В целом они нормально дружат, но всё же.

Посмотрите в журналах, может там подсказка с чем они в драку вступают.

Попробуйте другую сборку клиента (на сайте есть) если вам можно, ОЧЕНЬ часто то, что сертификаты ФСБ и ФСТЭК имеет очень много косяков имеет,

которые оперативно не могут исправить.

Ну и не исключении CSP которое так же имеет кучу проблем.

И рекомендую ОБЯЗАТЕЛЬНО отключить ддурное обновление ОС!!! Там столько "Г" лезит без контрольно, что ужас. Потому если что то надо то обновили в ручную, проверили что всё номрально и оставили. Если что то начинает сбоить то ищите подставные KB-шки.

Я всё же грешу на KES, буду с ним еще пробовать различные варианты. В журналах никаких ошибок нет в том то и дело. Собрал вчера полные логи VipNet Client через командную строку, для диагностики (в cmd -limpdiag -a -вычитал тут на форуме) там тоже все хорошо, ошибок нет. Сборки пробовал версий Client_RUS_4.3.2.37273 и Client_RUS_4.2.1.23386 - результат одинаков. Да и в системах обновления отключены...

 

7 часов назад, KIV сказал:

4.3.2 не очень, 4.3.1 пользуетесь. Основное в 4.3.2 это поддержка Win 10, у вас как я понял их нет.

На моей рабочей машине стоит Win 10 x64 и на нее 4.3.2 не ставится хоть убей! Хотя на сайте и пишут что именно 4.3.2 имеет поддержку 10-ки. Установил client на 10-ку вообще чудесным образом ) 4.2 версия ставилась без ошибок, но для запуска монитора требовала файл в системе itckcsp64.sys, в самих инсталяторах программы такого файла нет, как и в системе. Разобрал инсталятор от версии 3.2 и обнаружил там файл itckcsp.sys, переименовал его в itckcsp64.sys, сунул в system32-drivers, перегрузил комп и всё заработало, и на моей 10-ке работает сейчас как ни в чем ни бывало. Такая же ситуация была с одной машиной на Win 7, с этим же файлом. Сделал по аналогии и тоже все отлично работает. Подсовывал файлик на проблемные машины, но результата не дает. Да и еще заметил, что если клиент вылетел с ошибкой и не запуская заново монитор, переустановить программу с дистрибутива, не перегружая комп по запросу, то монитор работает без сбоев.

Приезжал к нам в контору специалист из инфотекс, разворачивал защиту на машинах, столкнулся с этими проблемами, руками развел и уехал, говорит типа я не знаю что за ошибки и первый раз такое вижу) 

Share this post


Link to post
Share on other sites

У инфотекса попросите утилиту checkaccess. она проверяет права доступа на директории и реестр перед установкой и в случае необходимости исправляет проблемы.

Share this post


Link to post
Share on other sites
22 часа назад, KGenn сказал:

Приезжал к нам в контору специалист из инфотекс, разворачивал защиту на машинах, столкнулся с этими проблемами, руками развел и уехал, говорит типа я не знаю что за ошибки и первый раз такое вижу) 

Ошибки правды бывают очень разные, а тем более с новой 10-й так вовсе караул, там в обновлениях не понятно что враги подсовывают.

Поставьте версию 3,2 пока, тут я писал и была тема, есть одна чудесная сборка которая работает там :-) В личку вам кину ссылочку.

Share this post


Link to post
Share on other sites
В 14.12.2016в00:55, Vintik сказал:

И рекомендую ОБЯЗАТЕЛЬНО отключить ддурное обновление ОС!!! Там столько "Г" лезит без контрольно, что ужас. Потому если что то надо то обновили в ручную, проверили что всё номрально и оставили. Если что то начинает сбоить то ищите подставные KB-шки.

Уважаемый, не стоит давать подобные советы для всех, на данном продукте свет клином не сошелся. Из собственного опыта - стоят на разных машинах все обновления Вин 7, куча ПО, в т.ч. КриптоПро, КонтинентАП и подобное, на протяжении многих лет полет нормальный. Проблемы с обновлениями возникают только у данного "продукта" и серьезные. Особенно хотелось бы отметить конфликты Вин 7 х86 с версиями 3.2.ххх, которые на данном ресурсе широко обсуждались. Теперь проблемы 4.3. с различными антивирусами (как Вам "внезапно" загрузка ОС в течении 30-120 мин.?), которые почему-то не обсуждаются вовсе, или здесь только администраторы ХВ-1000 тусуются, а из клиентов и нет никого?

Извините если что не так, ищу ответы, наболело.

Share this post


Link to post
Share on other sites
3 часа назад, adm-svg сказал:

....

Извините если что не так, ищу ответы, наболело.

Ну так потому что вы следите, мне то всё равно извиню или нет, а если к вам попрут потом звонки, что вдруг перестала работать ваша отчётная программа... а знаете из за чего - на "Г" вин-10 обновились и многие даже не чего не делали... потом не вовремя сданные отчёты - штрафы, объяснительные т.к. штрафы там ого-го...

1) Так что пусть эти клиенты вас извиняют - вот вам и первый ответ.

2) Где вы видите, что тут советы всем? )))) ой рассмешили - тут совета только тем кто на грабли наступил и ищет обход. Я тоже у себя и на других ПК где требуется, поддерживаю все обновления и по мере их поступления и проблем ищу выход, но делаю это контролируя результат и с пониманием, что лишнее не ставить. А у многих настроена что то вроде ЗПС - потому там обновления только по острой необходимости, а в остальном они вовсе не нужны и работает всё стабильно т.к. нет там не чего лишнего.

3) "Внезапно" загрузка ОС в течении 30-120 мин - это как раз очень даже нормально принимая бесконтрольно все подряд обновления :-) Не чего не бывает просто так в отлаженном механизме. Система в домене? Внезапно на вас на травили дос атаку, вот это внезапно. Внезапно отработала система безопасности и всё отрубила извне или тот самый внезапные лишился "всего" - это один из сценариев. А теперь ройте в аудите журналов, смотрите и надейтесь что это реально был даже пусть сбой HDD, а не проникший зловред который эмулировал сбой и ваши данные уже выкачены в тихую....

Так что давайте не болейте там в тихую!!!

А присоединяйтесь к "наболевшим" и когда нас много то это не сумасшествие, т.к. сума сходят по одиночке, а мы тут весело обсуждаем наболевшее т.к. что нам ещё остаётся. Кто то плачет, кто то смеётся, кто то уйдёт, а кто то вернётся ;-)   

Share this post


Link to post
Share on other sites
25 минуты назад, Vintik сказал:

А присоединяйтесь к "наболевшим" и когда нас много то это не сумасшествие, т.к. сума сходят по одиночке, а мы тут весело обсуждаем наболевшее т.к. что нам ещё остаётся. Кто то плачет, кто то смеётся, кто то уйдёт, а кто то вернётся ;-)   

Зачем так много слов? Я всего лишь имел ввиду, что описанные проблемы возникают у нашего любимого продукта, а у других, аналогичного назначения и отечественного производства - нет. С ними нет необходимости контролировать последствия каждого обновления, просто работают. Очень хочется надеяться, что и ВипНет скоро будет таким, поскольку Вы совершенно правы, что никуда мы от него не денемся. Но года идут, а.....

по 3) да все просто, без происков, обновился антивирус и...

Share this post


Link to post
Share on other sites
2 часа назад, adm-svg сказал:

Зачем так много слов? Я всего лишь имел ввиду, что описанные проблемы возникают у нашего любимого продукта, а у других, аналогичного назначения и отечественного производства - нет. С ними нет необходимости контролировать последствия каждого обновления, просто работают. Очень хочется надеяться, что и ВипНет скоро будет таким, поскольку Вы совершенно правы, что никуда мы от него не денемся. Но года идут, а.....

по 3) да все просто, без происков, обновился антивирус и...

Да ладно вам драматизировать. Вот всеми "любимая" ОС - вы в курсе что недавно 10-ка пол мира оставила без интернета, потом извинялась, что не то обновление выслали :-)

А то что в эксели при не верной формуле бывает документ потом по 20-30 минут ждут пока отвиснет (не было у вас? а у меня было и уже просто приходится удалять формулы..)

А то что после обновления Ворда люди не могут отправить в почту как привыкли из ворда, т.к. там кракозябры вместо текста.

...

Так что поверьте глюков везде много и такая уж работа, а то вы хотите чтоб дождь шёл и капал всегда в одни и те же лунки - так не бывает ;-)

Share this post


Link to post
Share on other sites
В 16.12.2016в07:11, KIV сказал:

У инфотекса попросите утилиту checkaccess. она проверяет права доступа на директории и реестр перед установкой и в случае необходимости исправляет проблемы.

Здравствуйте, если есть такая утилита ссылочку можете кинуть ?

Share this post


Link to post
Share on other sites
51 минуту назад, denis.r сказал:

Установите версию 4.2.5 http://infotecs.ru/downloads/beta-versii/vipnet-csp-4-2-5-43460-windows-rus.html?show_form=Y в ней проблема с правами доступа решена.

Ставил, не помогло. У меня есть ПК c Windows 8.1, стоял 4.3.2, была необходимость удалить ViPnetClient. Удалил, ставлю опять ViPNet_4.3.2.- не ставится, 4.3.1 - не ставиться, 3.2.9 - не ставится - падает с сообщением - Недопустимые данные 0xD.

Share this post


Link to post
Share on other sites
2 минуты назад, fowoku сказал:

Ставил, не помогло. У меня есть ПК c Windows 8.1, стоял 4.3.2, была необходимость удалить ViPnetClient. Удалил, ставлю опять ViPNet_4.3.2.- не ставится, 4.3.1 - не ставиться, 3.2.9 - не ставится - падает с сообщением - Недопустимые данные 0xD.

Так у Вас совсем другая проблема. Утилита Вам не поможет. Удаляйте антивирус и повторите установку.

Share this post


Link to post
Share on other sites
2 минуты назад, denis.r сказал:

Так у Вас совсем другая проблема. Утилита Вам не поможет. Удаляйте антивирус и повторите установку.

В том то и дело, что антивируса - нет, хотя ща напомнили - буду отключать Защитник Windows.

Share this post


Link to post
Share on other sites

Ещё такое было как отписывали, у меня лично когда "хвосты" от старых папок остались. Пока в рукопашную их не снёс мне тоже так ругалось.

Share this post


Link to post
Share on other sites

Антивируса нет, защитник выключил, все папки, ветки реестра отчистил, не ставится ViPNetClient. Пока пробую версию 3.2.9, на этапе установки слишком быстро "пролетает" окно командной строки, где что-то должен делать NETSH. и после этого идет откат обновления и ошибка Недопустимые данные. Болше не знаю  - куда копать. Поэтому думал, мож утилита поможет, мож где прав нету - она покажет.

Share this post


Link to post
Share on other sites

Посмотрите что со службой брэндмауэра windows. Служба не должна быть остановлена при установке клиента.

Share this post


Link to post
Share on other sites
В 06.03.2017в13:36, fowoku сказал:

Может кто помочь с анализом лог-файла установки ViPNetClient ?

На сапорт напишите если это у вас регулярно продолжается. Они конечно ответят не сразу или вовсе не ответят, но если у вас 25 машин, то думаю в их интересах будет понять от чего и какое ПО этому предшествует.

\ Вот у меня тест на Андроиде и OS-X был.. это не кому не интересно т.к. там очень сырые клиенты.. но всё же практика показала, что на реальном Андроиде завелось.. думаю и на МАК-е пошло бы, а на моих вирт. ОС всё запускается но связи нет хоть ты что делай... так что отправил. может подумают если интересно им будет.

А у вас реальная сеть. Так что я мне кажется это какое то ПО или точно каспер балуется.. добавьте в исключения випнет (хотя это думаю сделано) 

Думаю это точно какое то ПО, т.к. вы пишите на разных ПК и на разных ОС.

Журналы с винда ещё посмотрите по ошибкам, обновление винда сделайте 1 раз и отключили, или сразу отключите. Что то точно у вас там ставит палки.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.