Jump to content

Recommended Posts

К сожалению, при попытке установить ПО на сервер, возникает ошибка.

[root@199681-1 distribute]# cat /proc/version
Linux version 2.6.32-642.el6.x86_64 (mockbuild@worker1.bsys.centos.org) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-17) (GCC) ) #1 SMP Tue May 10 17:27:01 UTC 2016

скачал distribute-x86_64-linux-4.1.4-10954.tar.gz

распаковал его.

запускаю ./install.sh и получаю ошибку

[root@199681-1 distribute]# ./install.sh
STEP 0: Checking system requirements
Checking presence of required system tools
Checking tool tar ... /bin/tar
Checking tool gunzip ... /bin/gunzip
Checking tool sed ... /bin/sed
Checking tool cat ... /bin/cat
Checking tool grep ... /bin/grep
Checking tool find ... /bin/find
Checking tool wc ... /usr/bin/wc
Checking tool awk ... /bin/awk
Checking tool make ... /usr/bin/make
Checking tool killall ... /usr/bin/killall
Checking tool pidof ... /sbin/pidof
Checking tool zcat ... /bin/zcat
Checking tool install ... /usr/bin/install
Checking tool rmmod ... /sbin/rmmod
Checking tool depmod ... /sbin/depmod
Checking tool lsmod ... /sbin/lsmod
Cannot find required tool: patch


в логах установки:

[18:37:35] Started installation process at Mon Jul 24 18:37:35 MSK 2017
[18:37:35] STEP 0: Checking system requirements
[18:37:35] Checking presence of required system tools
[18:37:35] Checking tool tar ... /bin/tar
[18:37:35] Checking tool gunzip ... /bin/gunzip
[18:37:35] Checking tool sed ... /bin/sed
[18:37:35] Checking tool cat ... /bin/cat
[18:37:35] Checking tool grep ... /bin/grep
[18:37:35] Checking tool find ... /bin/find
[18:37:35] Checking tool wc ... /usr/bin/wc
[18:37:35] Checking tool awk ... /bin/awk
[18:37:35] Checking tool make ... /usr/bin/make
[18:37:35] Checking tool killall ... /usr/bin/killall
[18:37:35] Checking tool pidof ... /sbin/pidof
[18:37:35] Checking tool zcat ... /bin/zcat
[18:37:35] Checking tool install ... /usr/bin/install
[18:37:35] Checking tool rmmod ... /sbin/rmmod
[18:37:35] Checking tool depmod ... /sbin/depmod
[18:37:35] Checking tool lsmod ... /sbin/lsmod
[18:37:35] Cannot find required tool: patch
[18:37:35] Exit with code 22
~
По мануалу ничего не сказано. 


Буду благодарен, если скажете куда копать или если предоставите внятный мануал. 

Спасибо.

Share this post


Link to post
Share on other sites

yum install patch ну или что-то типа того. Ошибка говорит о том что нет программы patch.

Share this post


Link to post
Share on other sites
7 часов назад, KIV сказал:

yum install patch ну или что-то типа того. Ошибка говорит о том что нет программы patch.

Да, спасибо. С этим я уже разобрался. Вчера обновил репы и установил patch.

Установка все равно дальше не идет, теперь ругается на 

[12:19:11] Checking Linux kernel headers presence...
[12:19:11] Unable to find valid kernel headers for kernel 2.6.32-642.el6.x86_64
[12:19:11] Installation ABORTED.
[12:19:11] Exit with code 23
 

вот что в системе установлено:

[root@199681-1 distribute]#  rpm -qa | grep kernel
kernel-firmware-2.6.32-642.el6.noarch
kernel-2.6.32-358.11.1.el6.x86_64
kernel-2.6.32-220.el6.x86_64
kernel-devel-2.6.32-696.6.3.el6.x86_64
kernel-2.6.32-71.29.1.el6.x86_64
kernel-headers-2.6.32-696.6.3.el6.x86_64
kernel-2.6.32-642.el6.x86_64
dracut-kernel-004-409.el6_8.2.noarch
 

Share this post


Link to post
Share on other sites

headersы нужны той же версии ядра, что и используется в данный момент. Судя по ошибке нужны 642, а у вас стоят 696.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.