Jump to content
basid

TLS на Windows 7 x64

Recommended Posts

На 64-разрядной Windows 7 для ViPNet CSP от (актуального) 4.2.2 до (бета) 4.2.9 сломана работа системного (schannel) TLS.
Если установить (под)компонент "Поддержка SSL/TLS", то при любых комбинациях параметров ViPNet CSP и системных настроек - отламывается "обычный" (не гостовый) TLS.
Internet Explorer не может отобразить любые https-сайты, не работает поиск в центре обновления и т.д.

Вопросы:
1. Проблема известна?
2. Решение (для Windows 7) планируется?

P.S. Вариант "удалить (не устанавливать) длинный-список-обновлений" - не предлагать.

Share this post


Link to post
Share on other sites

Отчасти. Были случаи когда ломался системный TLS, были соотвествующие исправления. Со времён 4.2.5 всё должно работать, и уж тем более на 4.2.9. Если хотите, давайте разбираться, от вас потребуется .nfo файл с информацией о системе (msinfo32). На чистую ОС ставили, или было какое-то шаманство с обновлением, удалением версий CSP или компонента TLS? 

Что касается длинного-списка-обновлений, то надо понимать что фраза "должны быть установлены все обновления" означает не все обновления в любой произвольный момент времени, а все обновления на момент выхода версии, которая устанавливается. Бывает так, что последующие обновления ОС ломают ранее работавший функционал, по очевидным причинам сам он вдруг не заработает, изменения могут внесены только в следующую версию. Поэтому, если не нужна именно сертифицированная версия CSP, желательно использовать последнюю с сайта.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.