Jump to content

Recommended Posts

Добрый день.

Используем Vip.Net 4.2 для 1С 8.3 на сервере Windows 2012. Стоят последние обновления для Windows.

Несколько раз в день при проведении базе вылетает 1С и в логе видим следующую ошибку:

Имя сбойного приложения: lsass.exe, версия: 6.2.9200.20521, метка времени: 0x505a9b98
Имя сбойного модуля: schannel.dll, версия: 6.2.9200.21954, метка времени: 0x57acbca7
Код исключения: 0xc0000005
Смещение ошибки: 0x0000000000006dfb
Идентификатор сбойного процесса: 0x264
Время запуска сбойного приложения: 0x01d4293c18d29f22
Путь сбойного приложения: C:\Windows\system32\lsass.exe
Путь сбойного модуля: C:\Windows\system32\schannel.dll
Идентификатор отчета: e20031ca-968d-11e8-94a8-005056876eb7
Полное имя сбойного пакета: 
Код приложения, связанного со сбойным пакетом: 

Подскажите, как решить данную проблему?

 

Share this post


Link to post
Share on other sites
7 минут назад, azz сказал:

CSP до бета версии обновите

У нас не стоит CSP, только Vip Net

Share this post


Link to post
Share on other sites

Вы не поверите, но ViPNet CSP входит в комплект ViPNet Client. Установите самую новую (бета) версию ViPNet CSP (на офф. сайте в разделе загрузок). Велика вероятность, что поможет.

Share this post


Link to post
Share on other sites

Бета версию на терминальный сервер на продакшене с 200 пользователями? А это безопасно?)))

Share this post


Link to post
Share on other sites

Мне кажется, что у человека все таки только CSP, клиентом там и не пахнет.

schannel вроде завязана с tls/ssl, тогда есть предложение проверить установлен ли компонент поддержки tls/ssl в vipnet csp, если установлен, то удалить.

В программах и компонентах найдите vipnet csp, нажмите изменить, добавить или удалить компоненты, там разверните компонент поддержка microsoft cryptoapi, отключите поддержку tls/ssl. Перезагрузитесь и потестите.

22 минуты назад, r1sh сказал:

Бета версию на терминальный сервер на продакшене с 200 пользователями? А это безопасно?)))

Ну если мой вариант не поможет, то можно боятся беты и сидеть дальше ребуты ловить )

Share this post


Link to post
Share on other sites
14 минут назад, R.Sheyn сказал:

Мне кажется, что у человека все таки только CSP, клиентом там и не пахнет.

schannel вроде завязана с tls/ssl, тогда есть предложение проверить установлен ли компонент поддержки tls/ssl в vipnet csp, если установлен, то удалить.

В программах и компонентах найдите vipnet csp, нажмите изменить, добавить или удалить компоненты, там разверните компонент поддержка microsoft cryptoapi, отключите поддержку tls/ssl. Перезагрузитесь и потестите.

Сделал как вы написали, посмотрю что будет.

Вообще странно что lsass вываливает ошибку schannel в момент проведения 1С.

У нас большой штат сотрудников, непонятно кто работает с этим компонентом.

В понедельник будет два сотрудника которые потенциально работают с ЭЦП, возможно кто-то из них.

Боюсь обновляться, вдруг у них что-то отвалится. Вдруг ключи не дай бог в реестре на сервере хранятся...

Если я от имени администратора запускаю Vip Net то он покажет мне все контейнеры или только моего пользователя?

Share this post


Link to post
Share on other sites
1 час назад, r1sh сказал:

Если я от имени администратора запускаю Vip Net то он покажет мне все контейнеры или только моего пользователя?

Затрудняюсь ответить, но мне думается, что только пользователя под которым вошли.

 

1 час назад, r1sh сказал:

Вообще странно что lsass вываливает ошибку schannel в момент проведения 1С.

Ну это вопрос к 1Сникам, каким боком 1С взаимодействует с этими компонентами. Вообще, если погуглить, то тема с bsod schannel и 1С достаточно распространенная, при этом проблемы различные, как криптопровайдеры Vipnet и Крипто-про, так и 1С сама может быть виновата.

Share this post


Link to post
Share on other sites
В 03.08.2018 в 18:39, R.Sheyn сказал:

Ну это вопрос к 1Сникам, каким боком 1С взаимодействует с этими компонентами. Вообще, если погуглить, то тема с bsod schannel и 1С достаточно распространенная, при этом проблемы различные, как криптопровайдеры Vipnet и Крипто-про, так и 1С сама может быть виновата.

вот как раз общался с 1С никами, они говорят что 1С никак вообще с этой библиоткой не работает. Это происходит в момент проведения базы, т.е. внутренняя обработка без каких-то внешних обращений.

Пока отключил компонент Windows Crypto API, ошибок не было. Жду появления ошибок, если появятся то попробую обновить приложение. Попутно выясняю кто вообще с ней работает)

Share this post


Link to post
Share on other sites
3 часа назад, r1sh сказал:

вот как раз общался с 1С никами, они говорят что 1С никак вообще с этой библиоткой не работает. Это происходит в момент проведения базы, т.е. внутренняя обработка без каких-то внешних обращений.

Пока отключил компонент Windows Crypto API, ошибок не было. Жду появления ошибок, если появятся то попробую обновить приложение. Попутно выясняю кто вообще с ней работает)

Cryptoapi целиком на мой взгляд не обязательно отключать, достаточно только tls/ssl

Share this post


Link to post
Share on other sites

Я бы сказал даже больше ...
Недостаточно отключить проблемный компонент в настройках ViPNet CSP - необходимо именно удалить компонент "Поддержка протокола TLS/SSL" через "Программы и компоненты" панели управления.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.