Jump to content

Recommended Posts

Дистрибутив: distribute-i686-linux-4.1.4-10171

ОС в vbox: ubuntu-14.04.5-desktop-i386

На 6 шаге установки ошибка, в логах вот что:

[22:29:49] Started installation process at Sat Oct 13 22:29:49 MSK 2018
[22:29:49] STEP 0: Checking system requirements
[22:29:49] Checking presence of required system tools
[22:29:49] Checking tool tar ... /bin/tar
[22:29:49] Checking tool gunzip ... /bin/gunzip
[22:29:49] Checking tool sed ... /bin/sed
[22:29:49] Checking tool cat ... /bin/cat
[22:29:49] Checking tool grep ... /bin/grep
[22:29:49] Checking tool find ... /usr/bin/find
[22:29:49] Checking tool wc ... /usr/bin/wc
[22:29:49] Checking tool awk ... /usr/bin/awk
[22:29:49] Checking tool make ... /usr/bin/make
[22:29:49] Checking tool killall ... /usr/bin/killall
[22:29:49] Checking tool pidof ... /bin/pidof
[22:29:49] Checking tool zcat ... /bin/zcat
[22:29:49] Checking tool install ... /usr/bin/install
[22:29:49] Checking tool rmmod ... /sbin/rmmod
[22:29:49] Checking tool depmod ... /sbin/depmod
[22:29:49] Checking tool lsmod ... /sbin/lsmod
[22:29:49] Checking tool patch ... /usr/bin/patch
[22:29:49] Checking Linux distribution support...
[22:29:49] Your Linux is supported
[22:29:49] Checking Linux platform(x64_64/i686/arm) support...
[22:29:49] Distribute is valid for current platform i686
[22:29:49] Checking ethtool...
[22:29:49] Found ethtool /sbin/ethtool
[22:29:49] Checking GCC version...
[22:29:50] Found GCC 4.8
[22:29:50] Checking Linux kernel headers presence...
[22:29:50] Kernel headers found in /lib/modules/4.4.0-31-generic/build/
[22:29:50] Running: grep LINUX_VERSION_CODE /lib/modules/4.4.0-31-generic/build//include/linux/version.h
grep: /lib/modules/4.4.0-31-generic/build//include/linux/version.h: No such file or directory
[22:29:50] Kernel headers validation code is 2, path /lib/modules/4.4.0-31-generic/build/
[22:29:52] Kernel headers validation is failed. Do you want to continue ? (y/n) y
[22:29:52] STEP 1: Select ViPNet installation distribution
[22:29:56] Selected distribution file: '/home/user/distribute/distribute.tar.gz'
[22:30:01] Do you want to continue installation? (y/n) y
[22:30:01] STEP 2: Unpacking ViPNet distribution archive
[22:30:12] Unpack '/home/user/distribute/distribute.tar.gz' successfull
[22:30:30] Do you agree to this License (y/n) y
[22:30:30] STEP 3: Searching for current ViPNet configuration
[22:30:30] No current ViPNet configuration found
[22:30:30] Selected installation type: INSTALL
[22:30:30] STEP 4: Preparing for installation
[22:30:30] Removing services sessions:
[22:30:30] /var/run/*.session
[22:30:30] /var/run/watch_app_list
[22:30:30] Copy rules.xsd file for convertor 
[22:30:30] Checking packet filtering method...
[22:30:30] Checking IPv6 support...
[22:30:30] Packet filtering method: NETFILTER
[22:30:30] This script will install
[22:30:30] ViPNet Virtual Private Network (i686/Linux) Product version: 4.1.4 build 10171
[22:30:58] Do you want to continue installation? (y/n) y
[22:30:58] STEP 6: Installing drivers
[22:30:58] Absent /lib/modules/4.4.0-31-generic/build/include/linux/version.h - make link to /lib/modules/4.4.0-31-generic/build/include/generated/uapi/linux/version.h
[22:30:58] Compiling drivers...
Kernel dir '/lib/modules/4.4.0-31-generic/build'
Kernel ver '4.4.0-31-generic'
Drivers build for kernel version 4.4.0-31-generic
/bin/sh: 48: [: =: unexpected operator
Your kernel version (4.4.0-31-generic) is not supported
make: *** [all] Error 1
[22:31:00] Error ocured during drivers compiling. See /var/log/vipnet_install.log for details.
[22:31:00] Installation ABORTED.
[22:31:00] Exit with code 16

 

Правильно я понимаю что версия ядра Linux не поддерживается? Пробовать Ubuntu 10.04? Или  какой дистрибутив лучше брать?

Share this post


Link to post
Share on other sites

А вы документацию читать пробовали или на первый попавшийся дистрибутив решили накатить? Прочтите, там все написано и версии ОС и версии ядер.

Share this post


Link to post
Share on other sites

В документации есть поддержка Ubuntu 10.04, но этот дистрибутив не нашел на сайте, т.к. он архивный уже видимо, надо поискать вообщем.

По документации можно проверить поддержку функционирования NETFILTER:

cat /proc/kallsyms | grep nf_reinject | wc -l

Если команда выдает 1 или больше, то NETFILET включен.

У меня выдал 4. Значит поддержка этой встроенной технологии есть. Вопрос почему тогда ошибка.

Share this post


Link to post
Share on other sites

На VirtualBox, кстати, можно установить HW-шный образ....

Тогда не нужно будет мучиться с выбором подходящего дистрибутива - можно тренироваться практически на настоящем координаторе!

Share this post


Link to post
Share on other sites
30 минут назад, volosnikov сказал:

На VirtualBox, кстати, можно установить HW-шный образ....

Тогда не нужно будет мучиться с выбором подходящего дистрибутива - можно тренироваться практически на настоящем координаторе!

Нужно поставить именно програмный координатор linux.

Share this post


Link to post
Share on other sites

Кто подскажет какой командой можно узнать точную поддержку (совместимость) дистрибутива ос линукс (ядра) с программным координатором linux, а также наличие в системе установленных необходимых модулей.

Share this post


Link to post
Share on other sites
3 минуты назад, bif сказал:

Нужно поставить именно програмный координатор linux.

В таком случае меня всегда выручал CentOS:
http://vault.centos.org

Качаете полный дистрибутив соответствующей версии, и вперед!
Обновлять из Интернета не советую, все брать со скаченного DVD

Share this post


Link to post
Share on other sites
15 часов назад, bif сказал:

Кто подскажет какой командой можно узнать точную поддержку (совместимость) дистрибутива ос линукс (ядра) с программным координатором linux

 В документации более, чем явно, написаны не только совместимые дистрибутивы, но и ядра в них:

В системе должно использоваться ядро Linux из подмножества версий 2.6.х (от 2.6.18 до 2.6.39 включительно) или 3.x (до 3.11 включительно).

Поддержка 4-х ядер появилась в актуальных версиях, но они пока не сертифицированы, впрочем, как и та, которую Вы сейчас устанавливаете. Сертифицирован билд 10954 и поддержки Ubuntu в нем нет.

 

 

Share this post


Link to post
Share on other sites
В 14.10.2018 в 18:16, volosnikov сказал:

В таком случае меня всегда выручал CentOS:
http://vault.centos.org

Качаете полный дистрибутив соответствующей версии, и вперед!
Обновлять из Интернета не советую, все брать со скаченного DVD

Сппсибо за совет!

Share this post


Link to post
Share on other sites
9 часов назад, zero сказал:

 В документации более, чем явно, написаны не только совместимые дистрибутивы, но и ядра в них:

В системе должно использоваться ядро Linux из подмножества версий 2.6.х (от 2.6.18 до 2.6.39 включительно) или 3.x (до 3.11 включительно).

Поддержка 4-х ядер появилась в актуальных версиях, но они пока не сертифицированы, впрочем, как и та, которую Вы сейчас устанавливаете. Сертифицирован билд 10954 и поддержки Ubuntu в нем нет.

 

 

В документации перечислены дистрибутивы:

 

В число гарантированно поддерживаемых дистрибутивов Linux входят:
Alt Linux Server и Desktop v. 6.0;
ALT Linux СПТ 7.0;
CentOS 5.7 и 6.4 (32/64-разрядная);
Mandriva Linux 2010 Powerpack;
RedHat Enterprise Linux 5.7 и 6.4 (32/64-разрядная);
Slackware Linux 12.2;
SUSE Linux Enterprise Server 10 (SP4) и 11 (SP3) (32/64-разрядная);
Ubuntu 10.04 (32/64-разрядная).
Все поддерживаемые дистрибутивы OS Linux должны быть для 32-й разрядной архитектуры.
С подробным списком можно ознакомиться в Руководстве пользователя по актуальной версии Координатора Linux.

 

Правильно понимаю что необходимо ставить только 32 битные версии ос линукс?

Share this post


Link to post
Share on other sites
В 15.10.2018 в 19:43, bif сказал:

В число гарантированно поддерживаемых дистрибутивов Linux входят:

Это где такая фраза? Я не нашел в документации.

В 15.10.2018 в 19:43, bif сказал:

Все поддерживаемые дистрибутивы OS Linux должны быть для 32-й разрядной архитектуры.

И снова мимо. Как же они могут быть 32, если выше через одну строку идут 64? В каком документе такое написано?

В официальном вот так:

На компьютере должна быть установлена ОС Linux одного из следующих дистрибутивов:
o ALT Linux 6.0 Server;
o ALT Linux 6.0 Desktop;
o ALT Linux СПТ 7.0;
o Astra Linux Special Edition 1.3;
o Astra Linux Special Edition 1.4;
o CentOS 5.7 (32/64-разрядная);
o CentOS 6.4 (32/64-разрядная);
o Mandriva Linux 2010 Powerpack;
o RedHat Enterprise Linux 5.7 (32/64-разрядная);
o RedHat Enterprise Linux 6.4 AS (32/64-разрядная);
o Slackware Linux 12.0 (только ядро 2.6.16.52 с FTP-сервера ftp://kernel.org);
o Slackware Linux 12.2;
o SUSE Linux Enterprise Server 10 SP4 (32/64-разрядная);
o SUSE Linux Enterprise Server 11 SP3 (32/64-разрядная);
o Ubuntu 12.04 (32/64-разрядная).

дальше про arm и:

Дополнительные требования
Работа ПО на других дистрибутивах Linux возможна, но не гарантируется. Также не гарантируется нормальная работа ПО ViPNet Coordinator Linux на одном компьютере совместно со сторонними средствами преобразования трафика, со сторонними средствами защиты, работающими на канальном, сетевом или транспортном уровне (в частности, ipchains и iptables), и со сторонними средствами шифрования трафика (IPSec и так далее).
В системе должно использоваться ядро Linux из подмножества версий 2.6.х (от 2.6.18 до 2.6.39 включительно) или 3.x (до 3.11 включительно).

Share this post


Link to post
Share on other sites
В 16.10.2018 в 22:06, zero сказал:

Это где такая фраза? Я не нашел в документации.

И снова мимо. Как же они могут быть 32, если выше через одну строку идут 64? В каком документе такое написано?

В учебном пособии "Администрирование ViPNet Coordinator Linux (версия 4) Гусев В.В. 2017 г."

В 16.10.2018 в 22:06, zero сказал:

В официальном вот так:

На компьютере должна быть установлена ОС Linux одного из следующих дистрибутивов:
o ALT Linux 6.0 Server;
o ALT Linux 6.0 Desktop;
o ALT Linux СПТ 7.0;
o Astra Linux Special Edition 1.3;
o Astra Linux Special Edition 1.4;
o CentOS 5.7 (32/64-разрядная);
o CentOS 6.4 (32/64-разрядная);
o Mandriva Linux 2010 Powerpack;
o RedHat Enterprise Linux 5.7 (32/64-разрядная);
o RedHat Enterprise Linux 6.4 AS (32/64-разрядная);
o Slackware Linux 12.0 (только ядро 2.6.16.52 с FTP-сервера ftp://kernel.org);
o Slackware Linux 12.2;
o SUSE Linux Enterprise Server 10 SP4 (32/64-разрядная);
o SUSE Linux Enterprise Server 11 SP3 (32/64-разрядная);
o Ubuntu 12.04 (32/64-разрядная).

Ставлю на CentOS release 5.7 (Final) Linux 2.6.18-274.el5 i686

Команда cat /proc/kallsyms | grep nf_reinject | wc -l

Выдает:
1

Значит пересборка ядра не требуется и NETFILER включен.

Запускаем установку ./install.sh

На 6 шаге установки выдает:

STEP 6: Installing drivers
Install drviplir.ko
Compiled driver drviplir.ko was not found to install.
Installation ABORTED.

Share this post


Link to post
Share on other sites

Ну как обычно, надо что то дополнять и использовать устаревшие ОС.

Я пробовал на "Slackware Linux 12.2" ранее, всё прошло сразу как по маслу.

Share this post


Link to post
Share on other sites
В 14.10.2018 в 20:39, volosnikov сказал:

На VirtualBox, кстати, можно установить HW-шный образ....

Тогда не нужно будет мучиться с выбором подходящего дистрибутива - можно тренироваться практически на настоящем координаторе!

А где это вы взяли образ и ключи потом? Мне один раз посчастливилось получить такое с сетью минимальной для тестирования, но всего лишь на 3 месяца и потом на этом всё закончилось, после истечения срока не чего больше не работало и выпросить уже бесполезно. Надо было простить сразу на ограничение не до опред. даты, а на время от установки, тогда было бы здорово постоянное удаление, установка и дальше просмотр.

Share this post


Link to post
Share on other sites
5 часов назад, Vintik сказал:

А где это вы взяли образ и ключи потом?

Образ - при апгрейде получили (официальные CD).
Ключи - наши боевые. Стенд же - виртуальный, для тренировок и экспериментов. Там свой ЦУС/УКЦ и все что нужно. Все в пределах одного виртуального хоста.
 

Share this post


Link to post
Share on other sites

А вы не путаете образ прошивки hw  с виртуальным исполнением hw-va?

Прошивки насколько мне известно фиг куда накатишь, кроме железок инфоткеса, они много параметров проверяют в том числе и dmi информацию матплаты.

Share this post


Link to post
Share on other sites

Ну. . .    нет, не путаю :ph34r:

HW - недешевое удовольствие, держать для тренировок - накладно, а молодых бойцов нужно учить поднимать кластер в удаленном офисе или менять IP на WAN-е без выезда на место в обстановке максимально приближенной.

Share this post


Link to post
Share on other sites

Всё чудесатее и чудесатее :-) Ну ладно, поверим на слово. Не будем раскрывать все тайны.

Share this post


Link to post
Share on other sites
3 минуты назад, Vintik сказал:

Всё чудесатее и чудесатее :-)

Вам не передали инсталляции при апгрейде на 4.x ?
Или вы не моделируете ситуации в виртуальном окружении на "боевых" infotecs.reg ??

Мужчины! B)

Share this post


Link to post
Share on other sites
24 минуты назад, volosnikov сказал:

Ну. . .    нет, не путаю :ph34r:

HW - недешевое удовольствие, держать для тренировок - накладно, а молодых бойцов нужно учить поднимать кластер в удаленном офисе или менять IP на WAN-е без выезда на место в обстановке максимально приближенной.

А расскажите как вы раскатили образ hw на виртуалку минуя проверки?)

Share this post


Link to post
Share on other sites
31 минуту назад, volosnikov сказал:

Вам не передали инсталляции при апгрейде на 4.x ?
Или вы не моделируете ситуации в виртуальном окружении на "боевых" infotecs.reg ??

Мужчины! B)

Мне кое как дали реги на 2 сети, сроком на 3 месяца, после долгих (где то 2 лет) выпрашиваний и то под НГ, когда до этого были 2 конфликтных проекта, где понаприсылали клиентам всё ломаное, да не то что им надо было (т.е. как обычно продажники лапшу навешали клиентам, а на деле тогда на версии 3,5 то что хотели не как не сделать, благо вроде было типа тестового запуска и кое как через всяких знакомых получили 4,2 которая сделал что хотел заказчик...) и вот после той "перебранки" я думаю тот человек видно был уже на веселе и наверно потому и удалось получить хоть на 3 месяца наконец то проверочный 2 мин сети с HW-VA, т.к. до этого приходилось только на приближённой схеме на линуксовых координаторах (3,7) и демо ключах что то пытаться ночами, а днями на боевых HW доделывать то, что нужно и можно только там.

Вот как то так. Потому потом время вышло и больше не чего не успел не сам не как вы заметили коллегам передать. студенты приходили и хоть виндовые схемы показал - откатываюсь на январь того года и можно показать что то, но только не HW-VA, там всё сложнее. Т.к. как обычно всё на пальцах, а потом уже махнул на всё это.

Share this post


Link to post
Share on other sites
6 минут назад, Vintik сказал:

Мне кое как дали реги на 2 сети, сроком на 3 месяца

Отматывали время назад? )

 

43 минуты назад, R.Sheyn сказал:

А расскажите как вы

Ну не на официальном форуме же ))) 

Share this post


Link to post
Share on other sites

На самом деле, софтварные координаторы - просто праздник! Особенно линуксовые.
Если узлы не требуют аттестации с наклейками на ПАК, то на них мы такое вытворяем!

И DHCP и пассивный альтернативный канал для тех же обновлений, даже телефонию отправили через passive node с переключением на основной в случае катастрофы...

Но законы жизни суровы.

[/реклама off]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.