Jump to content

Recommended Posts

Добрый день. Поиск по форуму не работает, проверить наличие аналогичных тем не смог, по этому создаю новую.

Используем в своем ЭДО подписи выданные УЦ ViPNet, в работе используется как vipnet csp отдельно, так и в составе vipnet client. На некоторых компьютерах, при подписании документа появляется ошибка "Полученный для функции буфер слишком мал". При использовании vipnet csp дело решается обновлением до версии 3.2.10, вопрос - как устранить ошибку если csp идет в составе vipnet client?

Share this post


Link to post
Share on other sites

Добрый день. Поиск по форуму не работает, проверить наличие аналогичных тем не смог, по этому создаю новую.

Используем в своем ЭДО подписи выданные УЦ ViPNet, в работе используется как vipnet csp отдельно, так и в составе vipnet client. На некоторых компьютерах, при подписании документа появляется ошибка "Полученный для функции буфер слишком мал". При использовании vipnet csp дело решается обновлением до версии 3.2.10, вопрос - как устранить ошибку если csp идет в составе vipnet client?

Вы VipNet CSP ставите вместе с VipNet Client? Какую версию VipNet Client используете?

Share this post


Link to post
Share on other sites

Может я не правильно описал проблему. Была аналогичная ситуация у пользователя (для подписи использует vipnet csp, идущий отдельным продуктом), дело решилось обновлением с версии 3.2.9 до 3.2.10.

Сейчас же у пользователя стоит vipnet client (3.2.9), следовательно используется csp в составе vipnet client'а. Если проблема решается только обновлением csp до версии 3.2.10, то как быть в ситуации когда на рабочем месте уже установлен vipnet client?

Share this post


Link to post
Share on other sites

Может я не правильно описал проблему. Была аналогичная ситуация у пользователя (для подписи использует vipnet csp, идущий отдельным продуктом), дело решилось обновлением с версии 3.2.9 до 3.2.10.

Сейчас же у пользователя стоит vipnet client (3.2.9), следовательно используется csp в составе vipnet client'а. Если проблема решается только обновлением csp до версии 3.2.10, то как быть в ситуации когда на рабочем месте уже установлен vipnet client?

Кстати говоря, можно попробовать поставить VipNet Client и VipNet CSP на один компьютер одновременно. Дело в том, что был опыт работы одновременно с VipNet CryptoService и VipNet Client на одном компьютере (не помню уже мотивов)... Но словом, мы заставили работать более новую версию криптопровайдера на компьютере с VipNet Client. Можно попробовать сделать здесь то же самое.

Share this post


Link to post
Share on other sites
Кстати говоря, можно попробовать поставить VipNet Client и VipNet CSP на один компьютер одновременно.

Был такой опыт, работает только местами.

Share this post


Link to post
Share on other sites

Был такой опыт, работает только местами.

Да, согласен, не с первого раза работает. Но докрутить можно... но муторно. больше подсказать ничего не могу.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.