Jump to content

Recommended Posts

Подскажите пожалуйста - какой архив необходим для установки VipNet на Linux.

Имеется dst сформированный то есть abn_001.dst. При инсталяции випнет просит dst. Находящийся в папке инсталяции dst - он не видит. Какие манипуляции необходимо произвести с ключевой информацией, чтобы она была видна установщиком vipnet.

Share this post


Link to post
Share on other sites

Если проблемы с автоматическим нахождением, то есть команда /sbin/unmerge.

Share this post


Link to post
Share on other sites

Извините - но я пока не могу представить себе целостной картины - не понимаю пока. В доках написано одно народ ставит совершенно по другому.

Запускаем ./install.sh далее происходит распаковка дистрибутива, и вот тут на этом этапе установщик не находит его - все же как он должен выглядеть - запакованным, или как есть dst. Насчет вашей команды - на этапе установки она должна применится? Некоторые админы вообще не патчат ядро, а только инсталят, initrd, ковыряют и все. Или что то еще?

Подскажите пожалуйста что и как если можете, а то как то не очь понятно, не селен в Linux.

Share this post


Link to post
Share on other sites

А возможно на Linux поставить только клиента без координатора? Ну как обычно клиент ставится на рабочую станцию?

И установка происходит в таком же виде как координатор?

Share this post


Link to post
Share on other sites

На Linux клиент и координатор - это один и тот же дистрибутив координатора. Всё зависит от того, какой DST подсунете. Указанную выше команду можно применять уже после установки. Почему у Вас на этапе установки dst не принялся - не знаю.

Share this post


Link to post
Share on other sites

Насколько я понял, он должен увидеть за архивированный dst. Но вот если даже его архивировать - он все равно его не видит, пишет указать директорию где оно лежит. Есть вообще какие ни будь методики по установке, отличные от тех что есть на инфотексе. У нас сотрудник учиться ездил, но там с Линуксом тем не затрагивали, а то что дали в описании то есть то что должны были проходить по теме курса - Линукс есть, но вот в нем нет некоторых моментов. И как быть не понятно.

Share this post


Link to post
Share on other sites

Зачем его архивировать? Просто поставьте через команду unmerge.

Share this post


Link to post
Share on other sites

Зачем его архивировать? Просто поставьте через команду unmerge.

Простите за глупый вопрос - но как это сделать - я вообще не селен в Linux-х - сейчас изучаю данные оси. Будьте любезны подскажите что с этой командой делать относительно dst.А насчет Linux верно то что если его не знать то наверное админом вряд ли можно называться.

Share this post


Link to post
Share on other sites

Я довольно давно последний раз разворачивал DST на linux, но отлично помню, что делал это командой unmerge, формат которой примерно таков:


/sbin/unmerge <file.dst> <каталог>

Под каталогом понимается транспортный каталог. Данная команда может ругнуться на права. В остальном - с ней проблем не бывает. Также ещё, вроде бы, припоминаю, что в каком-то файле также указывается пароль на пользователя, под которым будет происходить авторизация. Но насчёт последнего не уверен. Linux координаторы на моей памяти у нас только один раз сбоили - нарушена была целостность справочника или ключа и я делал инициализацию ещё раз. В остальном - работают стабильно без нареканий. С HW, конечно, мороки ещё меньше.

Share this post


Link to post
Share on other sites

Что то никак не пойму "/sbin/unmerge <file.dst> <каталог>" здесь должен лежать dst - ?. Если честно вообще не представляю как ему подсунуть дистрибутив, каким образом он его найти должен.

Смотрел установку на примере AltLinux только вот там он его отображает что есть dst выбираешь цифру и пошла установка. Ну а в моем случае он ничего не находит. А транспортный каталог в каком смысле - это - транспортный? На примере той же fedora там видимо в примере имеется ввиду демонстрационный ключ - и все что с ним связано представляет архив. Так вот этот архив он видит автоматом происходит установка - только ключей о в нем нет. По этому установка и не происходит в том смысле в каком она должна быть, процентовка бежит и все такое - а в конце dst не найден. В общем печально все как то.

Share this post


Link to post
Share on other sites

Я Вам написал конечную команду. Когда всё установлено, но не проинициализировано - можете запустить unmerge в параметре указав DST без всяких автоматических поисков. А каталог - это путь, куда распаковывать DST. На память не помню точный путь.

Share this post


Link to post
Share on other sites

Я Вам написал конечную команду. Когда всё установлено, но не проинициализировано - можете запустить unmerge в параметре указав DST без всяких автоматических поисков. А каталог - это путь, куда распаковывать DST. На память не помню точный путь.

В описании имеется команда что вы описали. В ней описано что нужно распаковать архив в котором есть dst. Ну да ладно /sbin/unmerge <file.dst>/iplir распаковки не происходит. И вообще каким образом здесь завязан каталог /sbin/ я создал /iplir в /etc. Но что то никак туда не попало.

В общем все как то странно.

А самое главное что первично распаковка самого архива - где имеется папка driver,aplication, и установка с последующей инициализацией ключевой информации, или же все таки с начало dst?

А вообще заметили только счас - что установки никакой не происходит - а получается что после принятия лицензионного соглашения, предлагается принять и установить VipNet, но вот после подтверждения установка прекращается.

И выдаются следующие ошибки;,

No carrent VipNet configuration found.

Не возможно создать обычный файл '/lib/modules/2.6.18-6-686/build/config': No such file or directory.

Can't found ethtool on your system.

Что бы могло это значить - не понятно. Если сталкивались с чем то таким - подскажите пожалуйста.

Share this post


Link to post
Share on other sites

Первична всё-таки установка VipNet. А вот с этой ошибкой увы - не сталкивался.

Share this post


Link to post
Share on other sites

Can't found ethtool on your system.

Пакет ethtool не установлен. Если Дебиан, Убунту и т.п. - sudo apt-get install ethtool

Share this post


Link to post
Share on other sites

Пакет ethtool не установлен. Если Дебиан, Убунту и т.п. - sudo apt-get install ethtool

Благодарю, за помощь!

Вопрос есть - а если ставили - на Linux - Клиент-Координатор - можете описать ход установки - зависимости для пакетов - это понятно - без них нельзя. Ну вот как все таки?

На Fedora сейчас пытаюсь поставить - ошибку пишет следующую.

/lib/modules/2.6.35.6-45.fe14.i686.PAE/build/config

Вроде бы ничего сложного не должно быть - установить пакеты - не обходимые - ну и инсталяция, и все - но вот как то все не просто.

Share this post


Link to post
Share on other sites

Подскажите пожалуйста - то есть на перечисленные ниже OS можно установить VipNet - ?

или же нет?

 ALT Linux 6.0 Server;

 ALT Linux 6.0 Desktop;

 CentOS 5.4;

 CentOS 5.7;

 CentOS 6.0;

 Mandriva Linux 2010 Powerpack;

 RedHat Enterprise Linux 5.4;

 RedHat Enterprise Linux 5.7;

 RedHat Enterprise Linux 6.0 AS;

 Slackware Linux 12.0 (only kernel 2.6.16.52 from the FTP server ftp://kernel.org);

 Slackware Linux 12.2;

 SUSE Linux Enterprise Server 10;

 SUSE Linux Enterprise Server 10 SP1, SP2, SP3;

 SUSE Linux Enterprise Server 11;

 SLES 11 SP1;

 Ubuntu 10.04.

Share this post


Link to post
Share on other sites

Можно.

Это список официально поддерживаемых дистрибутивов Linux для ViPNet Координатора из админ-гайда. Хотя и на другие дистрибутивы тоже ставится успешно. Например, ставили на Arch Linux разных версий (с ядрами от 2.6 до 3.6).

Главное чтобы x32 были, правильная версия ядра и все необходимые пакеты были предварительно установлены.

Share this post


Link to post
Share on other sites

Можно.

Это список официально поддерживаемых дистрибутивов Linux для ViPNet Координатора из админ-гайда. Хотя и на другие дистрибутивы тоже ставится успешно. Например, ставили на Arch Linux разных версий (с ядрами от 2.6 до 3.6).

Главное чтобы x32 были, правильная версия ядра и все необходимые пакеты были предварительно установлены.

Вот пытался ставить на Debian,Fedora. Fedora - умерла после загрузки некоторых пакетов - не грузится и все застывает на заставке - и все.

Что на Fedore что на Debian - ошибка вот эта - почему не ставится не понятно -"/lib/modules/2.6.35.6-45.fe14.i686.PAE/build/config" - может вы подскажите?А

то что то никак не получается - на Fedoru нашел описание установки - все делал как написано - пакеты все поставил, вроде все понятно - но вот что то никак.

Share this post


Link to post
Share on other sites

C ошибкой "/lib/modules/2.6.35.6-45.fe14.i686.PAE/build/config" не сталкивался.

Physical Address Extension (PAE) — режим работы встроенного блока управления памятью x86-совместимых процессоров, в котором используются 64-битные элементы таблиц страниц (из которых для адресации используются только 36 бит), c помощью которых процессор может адресовать 64 ГБ физической памяти (вместо 4 ГБ, адресуемых при использовании 32-разрядных таблиц).

В ядре Linux поддержка PAE имеется начиная с версии 2.3.23. Оно поддерживает до 64 Гб ОЗУ, но требует от процессора поддержки PAE. Также для включения PAE необходимо пересобрать ядро с параметром PAE (CONFIG_X86_PAE=y). Поскольку это не всегда удобно, большинство дистрибутивов включили в свои репозитории готовые ядра с этим параметром. Также последние версии многих дистрибутивов поставляются по умолчанию с ядром, в котором включена поддержка PAE.

Если у вас памяти меньше 4 Гб, то попробуйте в ядре отключить PAE, возможно в этом причина.

Share this post


Link to post
Share on other sites

C ошибкой "/lib/modules/2.6.35.6-45.fe14.i686.PAE/build/config" не сталкивался.

Если у вас памяти меньше 4 Гб, то попробуйте в ядре отключить PAE, возможно в этом причина.

Благодарю за совет - попробую! А что значит "Это список официально поддерживаемых дистрибутивов Linux для ViPNet Координатора", с ними клиент и координатор работают как то лучше - или же установка проходит иначе!

Ну а сами то как ставили - так как в описании к установке на Linux? Или же так же - с бубном и плясками?:)

Share this post


Link to post
Share on other sites

Это означает, что с данным списком дистрибутивов гарантируется работа ПО ViPNet. Если необходимого дистрибутива в этом списке нет, это означает, что разработчик не гарантирует работоспособность ПО в данном случае.

Share this post


Link to post
Share on other sites

В нете нашел установка Координатора на Fedora - как раз мой вариант, но опять же процесс завершается с ошибками ПО так и не устанавливается.

Не пойму в чем причина - что не так, вот лог с Оси - может ктонить чтонить подскажет?

vipnet_install.log

[16:50:53] STEP 1: Select ViPNet install distribution

[16:50:56] Selected distribution file: '/iplir/distribute/distribute.tar.gz'

[16:51:00] STEP 2: Unpack ViPNet distribution archive

[16:51:00] Unpack '/iplir/distribute/distribute.tar.gz' successfull

[16:51:13] STEP 3: Find current ViPNet configuration

[16:51:13] No current ViPNet configuration found

[16:51:13] Selected install type: INSTALL

[16:51:13] STEP 4: Prepare for installation

[16:51:13] Remove services sessions:

[16:51:13] /var/run/*.session

[16:51:13] /var/run/watch_app_list

[16:51:13] Check packet filtering method...

[16:51:13] Packet filtering method: NETFILTER

[16:51:13] This script will install

[16:51:13] ViPNet Virtual Private Network (i386/Linux) Product version: 3.7.1 build 2757

[16:51:14] Check Linux distribution support...

[16:51:14] Linux distribution supported

[16:51:14] Check ethtool...

[16:51:14] Found ethtool /sbin/ethtool

[16:51:14] Check GCC version...

[16:51:14] Found GCC 4.5

[16:51:14] STEP 5: Install drivers

[16:51:14] Compiling drivers...

Makefile:23: /lib/modules/2.6.35.6-45.fc14.i686.PAE/build/.config: Нет такого файла или каталога

make: *** Нет правила для сборки цели `/lib/modules/2.6.35.6-45.fc14.i686.PAE/build/.config'. Останов.

[16:51:14] Error ocured during drivers compiling. See /var/log/vipnet_install.log for details.

[16:51:14] Installation ABORTED.

[16:51:14] Exit with code 16

Share this post


Link to post
Share on other sites

Вот в чем проблема Makefile:23: /lib/modules/2.6.35.6-45.fc14.i686.PAE/build/.config: Нет такого файла или каталога

Нужно поставить исходные коды ядра или хотя бы заголовочные файлы. В Fedora это пакеты kernel-sources иди kernel-headers соответственно.

Еще советую отказаться от ядра с PAE. Думаю с ним не соберется....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.