Jump to content
Sign in to follow this  

Recommended Posts

Может кому пригодится...

В процессе обновления с Vipnet CSP 3.2 на 4.0 схватил проблему - прогресс установки полностью заполнился, а после вылетает ошибка 1603 и кнопка ОК. Затем все без откатывается.

В процессе выяснилось

От предыдущей установки остались помеченные на удаление при перезагрузке, но не удаленные драйвера. Перезагрузка не помогала. Инсталятор на этом событии спотыкался.

Помогло вручную удалить ветки в реестре отмеченные на удаление (создан ключ внутри ветки реестра), но не удаленные:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Itckcng64

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Itckcsp64

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Itcspe64

В разборках помог журнал:C:\ProgramData\InfoTeCS\InstallerData\ViPNet CSP\Logs\Setup.msi_2014-7-22-20-18-54.log

Конкретное место

....

ITCCA - {2014/07/22 20:13:38}: CheckDriverPermissions started.

ITCCA - {2014/07/22 20:13:38}: CustomActionData = Itckcng64

ITCCA - {2014/07/22 20:13:38}: Driver Itckcng64 check manual.

ITCCA - {2014/07/22 20:13:38}: Driver Itckcng64 check failed. Error code = 1072, (0x430) - Указанная служба была отмечена для удаления.

.

CustomAction CheckServicePermissionsItckcng returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Action ended 20:13:38: InstallFinalize. Return value 3.

....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.