Jump to content
Ярослав

не работает TLS ГОСТ WIn 8.1, Vipnet CSP 4.2.5

Recommended Posts

ОС Windows 8.1, устанавливали версию Vipnet CSP 4.2.5. не работают сайты с https ГОСТ (негостовые https открываются успешно). Антивируса нет (новая система). Если удалить Vipnet CSP и установить Криптопро CSP 3.9 или 4.0 HTTPS работает корректно. поддержка TLS/ssl включена. 

На другой машине c ОС Win 10 так же  устанавливали версию Vipnet CSP 4.2.5. гостовые сертификаты открываются с ошибкой "при проверке отношений доверия произошла системная ошибка", HTTPS гост не работает. Переустановка Vipnet CSP не помогает. Удаление vipnet csp и установка криптопро csp помогает, но требуется использование криптопровайдера Vipnet.

В чем может быть проблема??

Share this post


Link to post
Share on other sites

Добрый день, Ярослав!

Можете уточнить, что в случае с ОС Windows 10, что с ОС Windows 8.1 компонент ViPNet CSP "Поддержка протокола TLS/SSL" установлен? Какой браузер Вы используете в том и в другом случае? На каких сайтах не работает https ГОСТ? В каком УЦ Вы получали сертификаты для работы в ViPNet CSP?

Share this post


Link to post
Share on other sites

Добрый день.

Компонент "Поддержка TLS\SSL" устанавливался(на Win 10 вручную как описано в рекомендациях). Браузер используем IE 11 (на Win 10 так же пробовали работать с Edge). Сайты наших информационных систем (https:\\sgo-s.edu71.ru например). УЦ у нас свой, аккредитованный.

Share this post


Link to post
Share on other sites

Вам известно, какой криптопровайдер используется на портале?

Share this post


Link to post
Share on other sites

Версия ниже 4.2.5?

Попробуйте у себя в 4.2.5 в настройках "Дополнительно" убрать галку Поддержка TLS 1.2 (см.в Руководстве пользователя Приложение А. Возможные неполадки и способы их устранения, стр. 178 https://files.infotecs.ru/_dl/sess/vipnet_csp/docs/ViPNet_CSP_User_Guide_Ru_4_5.pdf)

Share this post


Link to post
Share on other sites

Хотел бы продолжить тему.

На всех машинах с Win 8.1 и версией бетты - 4.2.5.35526,  при соединении с https://portal.rosreestr.ru:4433/cxf/External?wsdl

Диалог выбора сертификата появляется но wsdl не появляется. Ошибка соединения. Лог теста утилитой из комплекта croptopro прилагаю. Галки в браузере и в настойках Vipnet CSP ни к чему не приводят.

test

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.