Jump to content
babichsa

Windows 10 не запускается после удаления ViPNet CSP 4.2

Recommended Posts

Windows 10 Professional не запускается после удаления ViPNet CSP 4.2.

Зависает до экрана приветствия. Помогает только восстановление из контрольной точки. Пробовал удаление через "Программы и компоненты" и через инсталятор. Результат одинаково плачевный.

Share this post


Link to post
Share on other sites

А какая версия ОС и версия CSP? Можно приаттачить .nfo файл, собранный тулзой msinfo32.exe после деинсталляции, также после деинсталляции остаются логи в C:\ProgramData\InfoTeCS\InstallerData\ViPNet CSP\Logs. Где-то с чем-то возник конфликт.

Share this post


Link to post
Share on other sites

Когда ставили? До обновления 1703 ? Возможно при удалении какие компоненты удаляет. Если попытаться обновить до последней бэтки ОС загружается? И потом удалить.

Share this post


Link to post
Share on other sites

Такая же проблема, после удаления vipnet csp, не грузится windows 10, обновил випнет до последней беттовской версии 4.2.9.4... удаляю випнет, перезагружал комп и все ОС не грузится, экран темнеет и дальше не грузится

Share this post


Link to post
Share on other sites

То же самое. Уважаемые разрабы, может не поленитесь написать, что теперь делать с бухгалтерским компом, с кучей клиент-банков, который был сломан этой омерзительной программой???

Share this post


Link to post
Share on other sites

Дефект и правда есть, Так же были зарегистрированы 2 случая, с 10-кой, на обоих "случайно" установили CSP не той версии (4) и после попытки удалить перезагрузка приводит к чёрному экрану. Выход был только вернуться до ближайшей точки. На одном, где требуется випент, потом ДО установки бух. ПО устоновили бэто ЦСП и потом ПО.

На втором надо было оставить другой ЦСП, удалось только вернуться на точку до установки, потому клиент решил сменить это ПК с 10-й пока не было поздно.

Но ошибка видно уже реально не хорошая. 

Share this post


Link to post
Share on other sites

При нынешнем объёме изменений, установка Windows 10 - реально нехорошая ошибка без всякой связи с ViPNet.

Share this post


Link to post
Share on other sites

Это понятно, но многие покупают что есть, а сейчас есть только 10-ка везде.

Share this post


Link to post
Share on other sites

... и право даунгрейда, если приобретать на работу "рабочие варианты". Ну и заранее обговаривать с продавцом вопросы с ключами.

Share this post


Link to post
Share on other sites

Вы же понимаете, у многих работа не связана с бесполезной работой за ПК, потому что их работа реально приносить пользу (печь хлеб, кормить людей, шить одежду и не оставить нагловиков голожопыми). Вот если бы нагловики сказали - вот вам, за то что вы нам будите дань платить нам и не отвлекайтесь от своей работы, то было бы куда легче всем.

Ну не чего, вот скоро освоятся с линуксом все и тогда появятся такие терминала - купил и работай, а нам всем придётся искать работу.

Но проблему с 10-кой надо решать, видно как Бил ушёл в отставку там совсем забыли на ГОСТы :-)

\ Скорее всего они спецально так делают, всё против нашей криптографии \

Share this post


Link to post
Share on other sites

Задача сисадмина-айтишника - создать рабочую среду. С учётом имеющихся возможностей и ограничений.
Пекарям-портным-плотникам надо принять как данность, что любая работа должна делаться специалистами: то, что можно давить next-next-next - ещё не означает, что "скрипач не нужен".

Share this post


Link to post
Share on other sites

Всё верно, тут не кто спорить не станет, но где таких как вы набрать? Вот и приходится им со всякими умниками мучиться :-(

Хотя тут это не решение, т.к. производитель заявляет о совместимости и штатной работе, а в итоге это лож. Пришли послушать прекрасную игру скрипоча, а получили скрип от которого зыби сводит)))) Понятно что шарлотан за это типа денег не берёт - сами пришли же, но всё равно не приятно. Хотя даже если продукт Випнет ЦСП станет платным, наверно всё останется на том же уровне т.к. проблемы идут от буржуазной ОС.

Share this post


Link to post
Share on other sites

Производитель тестировал сборку ViPNet-клиента на той сборке Windows 10, которая была в то время. И, скорее всего, это была RS1.
С тех пор вышла ещё парочка сборок десятки. Каждая из которых могла много чего отломать.

Share this post


Link to post
Share on other sites

Это понятно, в этом то и вопрос - почему такая не "хилая" компания, пытающая быть лидером, так медленно реагирует на изменения? Уже ка пол годы будет например что не совместима с НОДОМ как висела надпись на сайте так и висит, понятно что хоть на этом спасибо - официально предупредили, но в остальном будут ждать пока не закончится сертификат на эту версию т.к. дорого исправлять сертифицированную версию и так со всеми продуктами (последний випнет 3,2 благо закончился, но так же столько косяков там было и неудобств с этим пользователям, а всем было на это поровну. Вот какая проблема у нас глобальная.

Потому всегда в работе будут применять по возможности не сертифицированные версии, а рабочие именно потому всегда под вопросом работа таких конролёров как ФСБ, ФСТЭК, а то находят потом уязвимости и не понимают - это же их косяки, сами пропустили и сразу не смогли найти или просто не было этой уязвимости.

Ладно, наше дело предупредить, в бето версиях то производители поправляют работу, потому есть надежда, что вот-вот новая бетка всем на радость выйдет.

Share this post


Link to post
Share on other sites

Столкнулся недавно тоже с такой же проблемой, после удаления vipnet CSP win 10x64 (сборка 1803) перестала загружаться ОС. На черном фоне бегают кружочки и на этом всё. До окна авторизации не доходило. Хотя в безопасный режим заходит без проблем. Отключение служб, удаление различных драйверов, чистка реестра вручную не дала результатов. 

Было сделано следующее. В безопасном режиме установил заново vipnet CSP. (как запустить службу Installer в безопасном режиме можно посмотреть в инете), после чего ОС загрузилась в обычном режиме как ни в чём не бывало. После этого удалил её программой Revo Uninstaller, при удалении не надо нажимать чтоб ОС сразу перезагрузилась, и сразу подчистить остатки от программы в реестре (Revo Uninstaller сам предложит это сделать и покажет все ветки которые остались). Я всё что он нашёл в реестре всё выделил и удалил. После перезагрузки ОС работает на ура.

Share this post


Link to post
Share on other sites

Ваша цель я понял была - удалить ViPNet CSP полностью, не восстановить работу?

Как вариант при чёрном экране, можно попробовать ещё на три кнопки и в ручную запустить "explorer.exe" - мне пару раз так везло, потом там ставил бэтку и всё начинало работать.

Share this post


Link to post
Share on other sites

А еще можно использовать актуальную версию csp с которой таких проблем нет. Наверняка ведь стояла 4.2.2, которая не поддерживает win10

Share this post


Link to post
Share on other sites
В 09.07.2018 в 12:56, aKudarov сказал:

Столкнулся недавно тоже с такой же проблемой, после удаления vipnet CSP win 10x64 (сборка 1803) перестала загружаться ОС. На черном фоне бегают кружочки и на этом всё. До окна авторизации не доходило. Хотя в безопасный режим заходит без проблем. Отключение служб, удаление различных драйверов, чистка реестра вручную не дала результатов. 

Было сделано следующее. В безопасном режиме установил заново vipnet CSP. (как запустить службу Installer в безопасном режиме можно посмотреть в инете), после чего ОС загрузилась в обычном режиме как ни в чём не бывало. После этого удалил её программой Revo Uninstaller, при удалении не надо нажимать чтоб ОС сразу перезагрузилась, и сразу подчистить остатки от программы в реестре (Revo Uninstaller сам предложит это сделать и покажет все ветки которые остались). Я всё что он нашёл в реестре всё выделил и удалил. После перезагрузки ОС работает на ура.

У меня Win 10. В Астрале дали ссылку почему то на Бета версию.

При ее установке выдает "ошибка при выполнении операции visual studio 2015 redistributable files".

Share this post


Link to post
Share on other sites
10 минут назад, alwol сказал:

У меня Win 10. В Астрале дали ссылку почему то на Бета версию.

При ее установке выдает "ошибка при выполнении операции visual studio 2015 redistributable files".

Смотрите логи установки visual studio 2015 redistributable это майкрософтовский компонент, что-то у Вас не в порядке с ОС, если "родные" компоненты не устанавливаются.

Инфотекс тут не при чем.

Share this post


Link to post
Share on other sites
56 минут назад, alwol сказал:

У меня Win 10. В Астрале дали ссылку почему то на Бета версию.

Потому что что у вас Win-10 как вы отписали, на неё вы можете попробовать поставить не бэту, но это 99,9% что у вас ОС рухнет...

Потому как писал уже не раз - всё у нас на бэтках и работает практически (а если 10-ка то буд вариантов, что КриптоПро, что Випнет...)

Какая у вас точно 10-ка?, хотя 10-ки они все одинаковые, тогда добавлю какой антивирус? И делаете ли запуск именно от "Рун ас" т.е. от админских "рутовских" прав.

И делайте точки отката в ручную перед такими работами -  очень рекомендую.

Share this post


Link to post
Share on other sites

Загрузился еще раз в  безопасном режиме с поддержкой сетевых драйверов - появился интернет по сети.

И установился VipNet. После двух перезагрузок ноут загрузился.

Но все равно нужно VipNet удалять. Не может он с КриПто Про дружить (а на нем у меня Аргос и  Сбис).

VipNet на Астрале работал, оплатил сертификат под КриПто Про.

Share this post


Link to post
Share on other sites

Может, но это сложно бывает с 10-кой ещё "веселее", если у вас есть КриптоПро уже, то вовсе нет смысла использовать Випнет. Любая подобная программа (та же 1С) не любит 2 криптопровайдера. У меня прекрасно они уживаются и работают, но конечно по API приходится уступать КриптоПро, а Випнет просто для своих целей.

 

Share this post


Link to post
Share on other sites
14 часов назад, Vintik сказал:

Может, но это сложно бывает с 10-кой ещё "веселее", если у вас есть КриптоПро уже, то вовсе нет смысла использовать Випнет. Любая подобная программа (та же 1С) не любит 2 криптопровайдера. У меня прекрасно они уживаются и работают, но конечно по API приходится уступать КриптоПро, а Випнет просто для своих целей.

 

Да я когда покупал и ставил Астрал под VitNet и не предполагал, что будет такая проблема. И меня не спросили и не предупредили. А когда поставил, Аргос перестал работать. Пришлось Аргос ставить на другой ноут. И отправлять отчеты с другого ноута, а получать ответы на рабочем.

Share this post


Link to post
Share on other sites
14 часов назад, Vintik сказал:

Может, но это сложно бывает с 10-кой ещё "веселее", если у вас есть КриптоПро уже, то вовсе нет смысла использовать Випнет. Любая подобная программа (та же 1С) не любит 2 криптопровайдера. У меня прекрасно они уживаются и работают, но конечно по API приходится уступать КриптоПро, а Випнет просто для своих целей.

 

 

32 минуты назад, alwol сказал:

Да я когда покупал и ставил Астрал под VitNet и не предполагал, что будет такая проблема. И меня не спросили и не предупредили. А когда поставил, Аргос перестал работать. Пришлось Аргос ставить на другой ноут. И отправлять отчеты с другого ноута, а получать ответы на рабочем.

Все верно, вот только это проблема не криптопровайдеров, а архитектуры ОС. Дело в том, что к майкрософтовскому cryptoapi может "прицепляться" только один криптопровайдер и в онлайне это не изменить.

Share this post


Link to post
Share on other sites
36 минут назад, alwol сказал:

И меня не спросили и не предупредили.

Не может быть, в инструкции по любой подобной проблеме есть ПРЕДУПРЕЖДЕНИЕ про два криптопровайдера, Просто проблема в том, что мы не когда не читаем инструкции. Вот для примера, что нашёл с ходу по вашему продукту тут -> Использование двух СКЗИ на одном ПК

Инструкцию не хочу их перечитывать, но поверьте на слово там это есть.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.